[网络]Chrome强制更新导致视频广告屏蔽失效如何解决?

(本文仅对旧版本的Chrome浏览器有效)

Chrome强制更新Flash至18.0.0.209,是因为Flash爆出重大漏洞,会导致运行Flash的木马网页可以入侵用户系统。

不过新版本的Flash会导致大部分的视频广告屏蔽扩展失效,而无法播放视频。那如何解决呢?

我们可以通过利用旧版本的Flash文件来覆盖新版本,让Chrome运行旧版本的Flash插件。

不过这样会让你的电脑暴露在漏洞的危险之下,因此强烈推荐你安装一款屏蔽网页Flash的插件,仅在常用的几个视频网站上开启Flash。

首先找到 Chrome 强制运行的新版本PepperFlash的文件位置,一般在:

C:Users[用户名]AppDataLocalGoogleChromeUser DataPepperFlash[版本号]

找到你旧版本的PepperFlash的文件位置,一般在:

C:Users[用户名]AppDataLocalGoogleChromeApplication[Chrome版本号]PepperFlash

之后关闭Chrome,把旧版本的 pepflashplayer.dll 文件覆盖到新版本里即可。

只要之前你的屏蔽广告插件可以运行,一般都可以用旧版本的Flash来覆盖新版本的,之后再运行Chrome,都可以重新屏蔽视频广告。

最后,记得在 chrome://plugins/ 里,关掉NPAPI的Flash插件而启动PPAPI的Flash插件。

Adblock plus(ABP)官网解决方案
1、打开chrome,在地址栏中输入chrome://plugins/
2、点该页面顶部右侧的“详细信息(Details)”
3、搜索”Adobe Flash Player”
4、这时可以看到Flash插件栏有2个版本
5、停用内置的Shockwave Flash(NPAPI)。
4、启动PPAPI的Flash插件,OK,现在可以使用你想要版本的flash player重新屏蔽视频广告了。

另外一种替代方案: 使用firefox浏览器屏蔽youtube视频广告!

扫一扫微信分享
[网络]Chrome强制更新导致视频广告屏蔽失效如何解决?的QR Code
文章分类 问答知识 标签:

发表评论

电子邮件地址不会被公开。 必填项已用*标注

*